Page 1 of 1

Mi3 scooter hack, firmware update

Posted: Wed Mar 16, 2022 3:17 pm
by MMI3
Hello! I want to ask for help. I didn’t read it properly afterwards and did a lot of nonsense. I have a mi3 scooter, I'm trying a hack, it worked properly, but I wanted to go back to the original system, the original files were in the link below the video, but I couldn't let them flash back. It was a bit confusing but since the roller worked so it wasn't a big deal. Then I tried the scooter hacking utility, it wrote here that SHFW is not installed, unfortunately I felt then the scooter display worked just did not respond to the accelerator pedal. I tried to put the working hack back, but I didn't let it back, now I can connect to the scooter via Bluetooth, but the serial number, BLE, is drv 0 from the programs. Can the scooter be brought back from this state? After reading that computer needs to be turned on and the original system installed, it just sounds like I just don't know what to add. Thanks in advance for the answers.

Re: Mi3 scooter hack, firmware update

Posted: Wed Jun 15, 2022 3:10 pm
by aaaargh
I've just done the same thing, because I'm an idiot. I uploaded the SHFW using the scooterhacking utility, I got A0 on the screen and the scooter just wouldn't apply power. Tried to roll back by installing the stock BLE (should have started with DRV, I guess) and now I have a dashboard that doesn't respond. Unplugging the dashboard and plugging it back in makes no difference.

I can only talk to the scooter over Bluetooth using the scooterhacking utility, as other utilities want the button to be pressed, and pressing the button doesn't do anything. I can't reinstall the SHFW as the SHFW API isn't there; I can't install a stock DRV or any other DRV because it can't see the DRV version. Basically I've ended up stuck. I assume that, if I could put back the BLE that's required, I could at least communicate with the scooter again - but it seems like I need to load the right BLE to make things work again.

Does anyone have a link to the correct BLE file to upload to fix this? I'm kicking myself here right now for leaping in and pressing buttons without knowing what they do :(

Re: Mi3 scooter hack, firmware update

Posted: Thu Jun 16, 2022 6:50 am
by aaaargh
For anyone else out there who lands on this thread: if you end up in a situation where you can talk to the scooter in the SH app but it shows no DRV version, and the button on the scooter does nothing, you “just” need to remove the bottom cover, disconnect the battery until the red light on the control board goes off, and reconnect it. Panic over!

Why they didn’t equip these things with a master power switch or reset button I’ll never know - but I’m thinking that a good mod would be to add such a cutout switch. Even a normally-closed push button which you’d have to hold for five seconds to reset the scooter would save the hassle of dismantling the scooter when this sort of thing happens. Maybe two wired in parallel to avoid accidental disconnects.

Thanks to this post for the method - note that on the mi3 the battery wires are black and red: viewtopic.php?f=9&t=711

Re: Mi3 scooter hack, firmware update

Posted: Mon Jan 30, 2023 1:49 pm
by RussellLake
I understand your excitement! Before installing any firmware update on your scooter, it's important to ensure that the update is released by the manufacturer and is safe to install. Additionally, it's also a good idea to back up any important data or settings before installing the update, in case of any unexpected issues during the process. Please note that installing firmware updates is done at your own risk and you should only use updates from a trusted source. If you encounter any issues with the update, it's best to reach out to the manufacturer for support.