ES100 no throttle

PTbig
Posts: 2
Joined: Fri Mar 27, 2020 11:37 pm

ES100 no throttle

Postby PTbig Fri Mar 27, 2020 11:51 pm

Good night.
I'm trying to use an okai F350 (ES100) scooter, with an Arduino I got the display and lights to work. If you rotate the engine on the display, the speed will appear. But the engine does not respond to the accelerator. The code I am using on Arduino is as follows:

Code: Select all

#include <Arduino.h> int PIN_SWITCH_1 = 13; int powerPin = LED_BUILTIN; byte messageOff[] = {0xA6, 0x12, 0x02, 0x90, 0x01, 0x42}; //If the scooter is on turn it off. byte messageA[] = {0xA6, 0x12, 0x02, 0x10, 0x14, 0xCF}; // MAKES HEADLIGHT BLINK CODE BEFORE STARTUP byte messageC[] = {0xA6, 0x00, 0x00, 0xF5, 0xFF, 0xFC}; // LIGHT ON & ESC ON & KPH & MAX SPEED & BLINK OFF & TURBO ON & FAST GAZ void setup() { Serial.begin(9600); pinMode (PIN_SWITCH_1, OUTPUT); pinMode(powerPin, OUTPUT); digitalWrite(powerPin, HIGH); Serial.write(messageOff, sizeof(messageOff)); delay(500); Serial.write(messageC, sizeof(messageC)); } void loop() { delay(500); Serial.write(messageC, sizeof(messageC)); }
How can I get the throttle to work?
Is it possible to put the firmware of another scotter in this, by JTAG? Example (Ninebot, xiaomi)

Best regards
PTbig
Posts: 2
Joined: Fri Mar 27, 2020 11:37 pm

Re: ES100 no throttle

Postby PTbig Wed Apr 22, 2020 8:42 pm

I finally got the accelerator to work :D


The Code I used is:
{0xA6, 0x12, 0x02, 0x35, 0x14, 0xF1}; // Speed Limit
{0xA6, 0x12, 0x02, 0x35, 0xFF, 0x38}; // Maximum Speed


In the first day I did 12km without any problem.
On the 2nd day I did 8 km without any problem.
Today after a long descent, and stopping to keep up the speed the ESC burned. :'(

Anyone with an extra ESC?

Best Regards

Return to “Okai / Electisan”

Who is online

Users browsing this forum: No registered users and 1 guest